$re = '/(.*\S)\n(?!\n)/m';
$str = 'this line should have a break
and this one
but not this one
and this one should
and this one
but not this one
and so on';
$subst = "$1 \n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;