const regex = /\{\{([a-zA-Z_][a-zA-Z_0-9]*)\}\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{([a-zA-Z_][a-zA-Z_0-9]*)\\}\\}', 'g')
const str = `{%
function check(a, b) {
if (\$object[a] && (b === undefined || \$object[b])) {
\$write("checked");
}
}
%}
<tr>
<td>{{name}}</td>
<td>{{description}}</td>
<td><input type="checkbox" {%%}="check('load');"></td>
<td><input type="checkbox" {%%}="check('load', 'test');"></td>
<td><input type="checkbox" {%%}="check('doc');"></td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}