$re = '/\{\{([a-zA-Z_][a-zA-Z_0-9]*)\}\}/';
$str = '{%
function check(a, b) {
if ($object[a] && (b === undefined || $object[b])) {
$write("checked");
}
}
%}
<tr>
<td>{{name}}</td>
<td>{{description}}</td>
<td><input type="checkbox" {%%}="check(\'load\');"></td>
<td><input type="checkbox" {%%}="check(\'load\', \'test\');"></td>
<td><input type="checkbox" {%%}="check(\'doc\');"></td>
</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);