import re
regex = re.compile(r"\{\{([a-zA-Z_][a-zA-Z_0-9]*)\}\}")
test_str = ("{%\n"
" function check(a, b) {\n"
" if ($object[a] && (b === undefined || $object[b])) {\n"
" $write(\"checked\");\n"
" }\n"
" }\n"
"%}\n"
" <tr>\n"
" <td>{{name}}</td>\n"
" <td>{{description}}</td>\n"
" <td><input type=\"checkbox\" {%%}=\"check('load');\"></td>\n"
" <td><input type=\"checkbox\" {%%}=\"check('load', 'test');\"></td>\n"
" <td><input type=\"checkbox\" {%%}=\"check('doc');\"></td>\n"
" </tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")