package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+ \w+ \(OBJECT\) \@[a-z0-9]+`)
var str = `SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590
SCALAR waypointVisible (ARRAY) @7ff70f56e030
NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90
ARRAY getPosATL (OBJECT) @7ff70f1e9df0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}