# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+ \w+ \(OBJECT\) \@[a-z0-9]+"
test_str = ("SCALAR_NaN ceil (SCALAR_NaN) @7ff710295590\n"
"SCALAR waypointVisible (ARRAY) @7ff70f56e030\n"
"NOTHING enableSatNormalOnDetail (BOOL) @7ff70f1a0d90\n"
"ARRAY getPosATL (OBJECT) @7ff70f1e9df0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.