using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.([^.][^.][^.]+|[^.][^o]|[^g][^.]|[^.])$";
string input = @".go
.og
.got
.ext
.properties
main.a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}