import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.([^.][^.][^.]+|[^.][^o]|[^g][^.]|[^.])$";
final String string = ".go\n"
+ ".og\n"
+ ".got\n"
+ ".ext\n"
+ ".properties\n"
+ "main.a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}