package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.([^.][^.][^.]+|[^.][^o]|[^g][^.]|[^.])$`)
var str = `.go
.og
.got
.ext
.properties
main.a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}