re = /\.([^.][^.][^.]+|[^.][^o]|[^g][^.]|[^.])$/m
str = '.go
.og
.got
.ext
.properties
main.a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end