#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(\.(?P<release>[a-z]+))?((?P<build>\d+))?"
Local $sString = "4.3.1" & @CRLF & _
"4.2.0.dev1" & @CRLF & _
"" & @CRLF & _
"1.0.0.a1" & @CRLF & _
"1.2.3.stable" & @CRLF & _
"2.2.2.dev" & @CRLF & _
"4.4.4.b3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")