$re = '/(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(\.(?P<release>[a-z]+))?((?P<build>\d+))?/m';
$str = '4.3.1
4.2.0.dev1
1.0.0.a1
1.2.3.stable
2.2.2.dev
4.4.4.b3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);