re = /(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(\.(?P<release>[a-z]+))?((?P<build>\d+))?/m
str = '4.3.1
4.2.0.dev1
1.0.0.a1
1.2.3.stable
2.2.2.dev
4.4.4.b3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end