package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(\.(?P<release>[a-z]+))?((?P<build>\d+))?`)
var str = `4.3.1
4.2.0.dev1
1.0.0.a1
1.2.3.stable
2.2.2.dev
4.4.4.b3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}