re = /(?P<symbol>[$¥£€₹])(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)(?:\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b)?\b|(?P<amount>\d{1,10}(?:[.,]\d{1,10})?)\h+(?P<currency>AUD|USD|GBP|EURO?S?)\b/m
str = '$20,000 AUD
$20,000
20,000 AUD
$
20,000
AUD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end