using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([ A-Za-z\-\.\']+), ([A-Za-z\-\.\']+( [A-Za-z\-\.\']+)*)$";
string input = @"These, are words
$!@#abcd^#$%# 1234
(hi&)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}