re = /^([ A-Za-z\-\.\']+), ([A-Za-z\-\.\']+( [A-Za-z\-\.\']+)*)$/
str = 'These, are words
$!@#abcd^#$%# 1234
(hi&)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end