package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([ A-Za-z\-\.\']+), ([A-Za-z\-\.\']+( [A-Za-z\-\.\']+)*)$`)
var str = `These, are words
$!@#abcd^#$%# 1234
(hi&)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}