$re = '/^([ A-Za-z\-\.\']+), ([A-Za-z\-\.\']+( [A-Za-z\-\.\']+)*)$/';
$str = 'These, are words
$!@#abcd^#$%# 1234
(hi&)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);