use strict;
my $str = 'azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r ';
my $regex = qr/(e\d|\\n)|[a-z]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";