// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(e\d|\\n)|[a-z]").unwrap();
let string = "azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r ";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}