import Foundation
let pattern = #"(e\d|\\n)|[a-z]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"azjf8ee7Ldoge \n Hmeqze= AZ12D Fs \nsdfz14eZe148r "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)