using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\{)[^}]*?\K\{(.*?)(?<!\\)\}";
string input = @"{{foo} {bar}} testing {none} 123 {nope {let's see if I can trick you \}...nope!} nope}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}