import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|\\{)[^\\}]*?\\K\\{(.*?)(?<!\\\\)\\}";
final String string = "{{foo} {bar}} testing {none} 123 {nope {let's see if I can trick you \\}...nope!} nope}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}