re = /(?:\G(?!\A)|\{)[^}]*?\K\{(.*?)(?<!\\)\}/
str = '{{foo} {bar}} testing {none} 123 {nope {let\'s see if I can trick you \\}...nope!} nope}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end