$re = '/(?:\G(?!\A)|\{)[^}]*?\K\{(.*?)(?<!\\\\)\}/';
$str = '{{foo} {bar}} testing {none} 123 {nope {let\'s see if I can trick you \\}...nope!} nope}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);