package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Seat\s(\d):\s([\w\s]+)\s\((\d+).*\)`)
var str = `Seat 1: fabulous29 (835 in chips)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}