import Foundation
let pattern = #"Seat\s(\d):\s([\w\s]+)\s\((\d+).*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Seat 1: fabulous29 (835 in chips)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}