const regex = /Seat\s(\d):\s([\w\s]+)\s\((\d+).*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Seat\\s(\\d):\\s([\\w\\s]+)\\s\\((\\d+).*\\)', '')
const str = `Seat 1: fabulous29 (835 in chips)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}