$re = '/Seat\s(\d):\s([\w\s]+)\s\((\d+).*\)/';
$str = 'Seat 1: fabulous29 (835 in chips)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);