#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<li>(?>[^<]+|(<[uo]l)>|<(?!\/?li)[^>]*>|(?R))*<\/li>(?(1)|(*F))"
Local $sString = "<li>Hi</li> - Just some text, should ignore" & @CRLF & _
"<li><ul><li>hi</li></ul></li> - Directly in <li>" & @CRLF & _
"<li>Hi<ul><li>hi</li></ul></li> - Plain text before the nested list" & @CRLF & _
"<li><strong>Hi</strong><ul><li>hi</li></ul></li> - HTML content before the nested list" & @CRLF & _
"" & @CRLF & _
"<ul><li>list item 1</li></ul>" & @CRLF & _
"<ul><li>list item 1</li><li><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>" & @CRLF & _
"<ul><li>list item 1</li><li>asdasdas<ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>" & @CRLF & _
"<ul><li>list item 1</li><li><strong>asdasdas</strong><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")