import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li>(?>[^<]+|(<[uo]l)>|<(?!\\/?li)[^>]*>|(?R))*<\\/li>(?(1)|(*F))";
final String string = "<li>Hi</li> - Just some text, should ignore\n"
+ "<li><ul><li>hi</li></ul></li> - Directly in <li>\n"
+ "<li>Hi<ul><li>hi</li></ul></li> - Plain text before the nested list\n"
+ "<li><strong>Hi</strong><ul><li>hi</li></ul></li> - HTML content before the nested list\n\n"
+ "<ul><li>list item 1</li></ul>\n"
+ "<ul><li>list item 1</li><li><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>\n"
+ "<ul><li>list item 1</li><li>asdasdas<ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>\n"
+ "<ul><li>list item 1</li><li><strong>asdasdas</strong><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}