use strict;
my $str = '<li>Hi</li> - Just some text, should ignore
<li><ul><li>hi</li></ul></li> - Directly in <li>
<li>Hi<ul><li>hi</li></ul></li> - Plain text before the nested list
<li><strong>Hi</strong><ul><li>hi</li></ul></li> - HTML content before the nested list
<ul><li>list item 1</li></ul>
<ul><li>list item 1</li><li><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
<ul><li>list item 1</li><li>asdasdas<ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
<ul><li>list item 1</li><li><strong>asdasdas</strong><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
';
my $regex = qr/<li>(?>[^<]+|(<[uo]l)>|<(?!\/?li)[^>]*>|(?R))*<\/li>(?(1)|(*F))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}