re = /<li>(?>[^<]+|(<[uo]l)>|<(?!\/?li)[^>]*>|(?R))*<\/li>(?(1)|(*F))/m
str = '<li>Hi</li> - Just some text, should ignore
<li><ul><li>hi</li></ul></li> - Directly in <li>
<li>Hi<ul><li>hi</li></ul></li> - Plain text before the nested list
<li><strong>Hi</strong><ul><li>hi</li></ul></li> - HTML content before the nested list
<ul><li>list item 1</li></ul>
<ul><li>list item 1</li><li><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
<ul><li>list item 1</li><li>asdasdas<ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
<ul><li>list item 1</li><li><strong>asdasdas</strong><ol><li>2.1</li><li>2.2</li><li>2.3</li></ol></li><li>list item 3</li></ul>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end