import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(_[A-Za-z])[^_\\n]+";
final String string = "abaisser_negation_pronominal_question\n"
+ "abaisser\n"
+ "abaisser_negation_voix_passive_pronominal";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}