import re
regex = re.compile(r"(_[A-Za-z])[^_\n]+")
test_str = ("abaisser_negation_pronominal_question\n"
"abaisser\n"
"abaisser_negation_voix_passive_pronominal")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)