const regex = new RegExp('^(?:(?:\\$|сум)(\\040)?(\\d{1,8})|(\\d{1,8})(\\040)?(?:\\$|сум))$', 'gm')
const str = `\$23
23\$
1000сум
сум1000
сум 1000
1000 сум
1000000000 сум`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}