re = /^(?:(?:\$|сум)(\040)?(\d{1,8})|(\d{1,8})(\040)?(?:\$|сум))$/m
str = '$23
23$
1000сум
сум1000
сум 1000
1000 сум
1000000000 сум'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end