import re
regex = re.compile(r"^(?:(?:\$|сум)(\040)?(\d{1,8})|(\d{1,8})(\040)?(?:\$|сум))$", flags=re.MULTILINE)
test_str = ("$23\n"
"23$\n"
"1000сум\n"
"сум1000\n"
"сум 1000\n"
"1000 сум\n"
"1000000000 сум")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")