const regex = /function[\s]*\(\s*([^)]*?)\s*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function[\\s]*\\(\\s*([^)]*?)\\s*\\)', '')
const str = `function (asd, asdas){
var sHEIGHT=21;
var sWIDTH=21;
var HEIGHT=300;
var WIDTH=400;
LAST_LOG_MSG='';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}