use strict;
my $str = 'function (asd, asdas){
var sHEIGHT=21;
var sWIDTH=21;
var HEIGHT=300;
var WIDTH=400;
LAST_LOG_MSG=\'\';';
my $regex = qr/function[\s]*\(\s*([^)]*?)\s*\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}