re = /function[\s]*\(\s*([^)]*?)\s*\)/
str = 'function (asd, asdas){
var sHEIGHT=21;
var sWIDTH=21;
var HEIGHT=300;
var WIDTH=400;
LAST_LOG_MSG=\'\';'
# Print the match result
str.match(re) do |match|
puts match.to_s
end