$re = '/function[\s]*\(\s*([^)]*?)\s*\)/';
$str = 'function (asd, asdas){
var sHEIGHT=21;
var sWIDTH=21;
var HEIGHT=300;
var WIDTH=400;
LAST_LOG_MSG=\'\';';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);