#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\+)|-"
Local $sString = "+123" & @CRLF & _
"-234" & @CRLF & _
"+456" & @CRLF & _
"-567"
Local $sSubst = "${1:+-:+}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)