use strict;
my $str = '+123
-234
+456
-567';
my $regex = qr/(\+)|-/mp;
my $subst = '${1:+-:+}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";