package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+)|-`)
var str = `+123
-234
+456
-567`
var substitution = "${1:+-:+}"
fmt.Println(re.ReplaceAllString(str, substitution))
}