$re = '/(\+)|-/m';
$str = '+123
-234
+456
-567';
$subst = "${1:+-:+}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;