#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(background:\s*url\((https?:\/\/)*[a-zA-Z0-9._:\/\s*]*\)\s*[a-zA-Z0-9\s*-._:\/;]*)"
Local $sString = ".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url(https://instant/templates/_default_/images/nyromodal/close.gif);" & @CRLF & _
"}" & @CRLF & _
".nyroModalCloseButton {" & @CRLF & _
" top: -13px;" & @CRLF & _
" right: -13px;" & @CRLF & _
" width: 12px;" & @CRLF & _
" height: 12px;" & @CRLF & _
" text-indent: -9999em;" & @CRLF & _
" background: url(../instant/templates/_default_/images/nyromodal/close.gif);" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")