# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(background:\s*url\((https?:\/\/)*[a-zA-Z0-9._:\/\s*]*\)\s*[a-zA-Z0-9\s*-._:\/;]*)"
test_str = (".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;\n"
"}\n\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(https://instant/templates/_default_/images/nyromodal/close.gif);\n"
"}\n"
".nyroModalCloseButton {\n"
" top: -13px;\n"
" right: -13px;\n"
" width: 12px;\n"
" height: 12px;\n"
" text-indent: -9999em;\n"
" background: url(../instant/templates/_default_/images/nyromodal/close.gif);\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.