const regex = /(background:\s*url\((https?:\/\/)*[a-zA-Z0-9._:\/\s*]*\)\s*[a-zA-Z0-9\s*-._:\/;]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(background:\\s*url\\((https?:\\\/\\\/)*[a-zA-Z0-9._:\\\/\\s*]*\\)\\s*[a-zA-Z0-9\\s*-._:\\\/;]*)', 'g')
const str = `.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(../instant/templates/_default_/images/nyromodal/close.gif);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}